Tests: add unix socket wrapper unit tests
[lttng-tools.git] / tests / Makefile.am
index 5feaca2d3003e6430885a689de44bd69a8b58ba9..8f5c15d34984eacea5519940a437de93544a628b 100644 (file)
@@ -1,12 +1,34 @@
-SUBDIRS = utils regression unit
+# SPDX-License-Identifier: GPL-2.0-only
 
-if USE_PYTHON
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
+
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
 else
-check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
+
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024208 seconds and 5 git commands to generate.