Tests: add unix socket wrapper unit tests
[lttng-tools.git] / tests / Makefile.am
index 99c20422e0cfbfca5231d3bd1046420f8e3c3fca..8f5c15d34984eacea5519940a437de93544a628b 100644 (file)
@@ -1,29 +1,13 @@
-SUBDIRS =
-DIST_SUBDIRS = utils regression unit stress
+# SPDX-License-Identifier: GPL-2.0-only
 
-if BUILD_TESTS
-SUBDIRS += utils regression unit stress
-endif
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
-installcheck-am:
 if BUILD_TESTS
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
-endif
-else
-       @echo "========================================="
-       @echo "WARNING: Tests were disabled at configure"
-       @echo "========================================="
-endif
-
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-if BUILD_TESTS
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
 endif
 else
        @echo "========================================="
@@ -31,8 +15,9 @@ else
        @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024905 seconds and 5 git commands to generate.