Tests: add unix socket wrapper unit tests
[lttng-tools.git] / tests / Makefile.am
index a95afa73e16dac810878f8aad28d10f78c96112a..8f5c15d34984eacea5519940a437de93544a628b 100644 (file)
@@ -1,5 +1,34 @@
-SUBDIRS = utils regression unit
+# SPDX-License-Identifier: GPL-2.0-only
 
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
+
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024103 seconds and 5 git commands to generate.