Fix: Tests: undefined `NR_USEC_WAIT` bash variable
[lttng-tools.git] / tests / Makefile.am
index d72b1ecd89fd30c94154c10e294d1a0cca1e4987..8f5c15d34984eacea5519940a437de93544a628b 100644 (file)
@@ -1,21 +1,23 @@
-SUBDIRS = utils regression unit stress
+# SPDX-License-Identifier: GPL-2.0-only
 
-installcheck-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
-endif
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023947 seconds and 5 git commands to generate.