Make lttng_directory_handle reference countable
[lttng-tools.git] / tests / Makefile.am
index 27570566b509c093d542ff266710aa5beae4d848..94ac152603d74cbcd2d7b91c7755df4dfa8bbedf 100644 (file)
@@ -1,13 +1,32 @@
-SUBDIRS = . tools kernel
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
+check-am:
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
 
-EXTRA_DIST = run-report.py test_list.py utils.sh utils.h
 
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS += ust
-endif # HAVE_LIBLTTNG_UST_CTL
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
 
-check-am:
-       ./runall.sh
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.026375 seconds and 5 git commands to generate.