Make lttng_directory_handle reference countable
[lttng-tools.git] / tests / Makefile.am
index 4824e2215f4dbc77b1c6c41c5a09f4097fb6c3bb..94ac152603d74cbcd2d7b91c7755df4dfa8bbedf 100644 (file)
@@ -1,3 +1,32 @@
-SUBDIRS = .
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
-dist_noinst_SCRIPTS = runall
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
+check-am:
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023658 seconds and 5 git commands to generate.