Make lttng_directory_handle reference countable
[lttng-tools.git] / tests / Makefile.am
index 9d4e0dc0d809fd00ea99085fcc565549a7c40c37..94ac152603d74cbcd2d7b91c7755df4dfa8bbedf 100644 (file)
@@ -1,18 +1,21 @@
-SUBDIRS = utils regression unit stress
+SUBDIRS =
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
-if USE_PYTHON
+if BUILD_TESTS
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
+endif
 else
-check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024745 seconds and 5 git commands to generate.