Select which binaries/extras to build at configure time
[lttng-tools.git] / tests / Makefile.am
index d72b1ecd89fd30c94154c10e294d1a0cca1e4987..99c20422e0cfbfca5231d3bd1046420f8e3c3fca 100644 (file)
@@ -1,18 +1,35 @@
-SUBDIRS = utils regression unit stress
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress
+
+if BUILD_TESTS
+SUBDIRS += utils regression unit stress
+endif
 
 installcheck-am:
+if BUILD_TESTS
        ./run.sh unit_tests
        ./run.sh fast_regression
 if PYTHON_BINDING
        ./run.sh with_bindings_regression
 endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
 
 check-am:
+if BUILD_TESTS
        ./run.sh unit_tests
        ./run.sh fast_regression
 if PYTHON_BINDING
        ./run.sh with_bindings_regression
 endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
 
 dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
 EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
This page took 0.024518 seconds and 5 git commands to generate.