Drop installcheck target
[lttng-tools.git] / tests / Makefile.am
index 9d4e0dc0d809fd00ea99085fcc565549a7c40c37..c7d4cd03a32f996106d09891ee0103f4d51c12b0 100644 (file)
@@ -1,18 +1,28 @@
-SUBDIRS = utils regression unit stress
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
+
+if BUILD_TESTS
+SUBDIRS += utils regression unit stress destructive
+endif
 
-if USE_PYTHON
 check-am:
+if BUILD_TESTS
+if HAS_PGREP
+       ./utils/warn_lttng_processes.sh $(PGREP)
+endif
        ./run.sh unit_tests
        ./run.sh fast_regression
+if PYTHON_BINDING
        ./run.sh with_bindings_regression
+endif
 else
-check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression root_destructive_tests
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README root_destructive_tests
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.029796 seconds and 5 git commands to generate.