Tests: add missing rotation and autoload tests to check target
[lttng-tools.git] / tests / regression / Makefile.am
index 7f146d48e1cace28583512fce4177f87fbe34d23..7752404056e322cd97ec2f9c899956d8f4199f69 100644 (file)
@@ -1,7 +1,7 @@
 SUBDIRS = tools kernel ust
 
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
+LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
 TESTS = tools/filtering/test_invalid_filter \
@@ -19,6 +19,7 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/snapshots/test_ust_streaming \
        tools/save-load/test_save \
        tools/save-load/test_load \
+       tools/save-load/test_autoload \
        tools/mi/test_mi \
        tools/wildcard/test_event_wildcard \
        tools/crash/test_crash \
@@ -29,7 +30,8 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
-       tools/rotation/test_save_load_mi
+       tools/rotation/test_save_load_mi \
+       tools/rotation/test_schedule_api
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -46,7 +48,9 @@ TESTS += ust/before-after/test_before_after \
        ust/test_event_basic \
        ust/test_event_tracef \
        ust/test_event_perf \
-       ust/blocking/test_blocking
+       ust/blocking/test_blocking \
+       ust/multi-lib/test_multi_lib \
+       ust/rotation-destroy-flush/test_rotation_destroy_flush
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.024075 seconds and 5 git commands to generate.