SoW-2021-0002: Custom 2.13 for ust-lower-urcu integration test.
[lttng-tools.git] / tests / regression / Makefile.am
index 403cf295a16bed42482cb5d245afa13b43aa8b66..89e1781b56cba97484be964ade2a6f5035ceafbf 100644 (file)
@@ -1,10 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+       $(top_srcdir)/tests/utils/tap-driver.sh
 
-TESTS = tools/filtering/test_invalid_filter \
+TESTS = tools/base-path/test_ust \
+       tools/channel/test_channel \
+       tools/filtering/test_invalid_filter \
        tools/filtering/test_unsupported_op \
        tools/filtering/test_valid_filter \
        tools/streaming/test_ust \
@@ -25,15 +29,18 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/crash/test_crash \
        tools/regen-metadata/test_ust \
        tools/regen-statedump/test_ust \
-       tools/notification/test_notification_ust \
-       tools/notification/test_notification_kernel \
+       tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_kernel_buffer_usage \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
        tools/rotation/test_save_load_mi \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
-       tools/working-directory/test_relayd_working_directory
+       tools/working-directory/test_relayd_working_directory \
+       tools/clear/test_ust \
+       tools/clear/test_kernel
+       tools/trigger/hidden/test_hidden_trigger
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -53,8 +60,14 @@ TESTS += ust/before-after/test_before_after \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
+       tools/metadata/test_ust \
+       tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
        ust/namespaces/test_ns_contexts \
-       tools/metadata/test_ust
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.024243 seconds and 5 git commands to generate.