SoW-2020-0002: Trace Hit Counters: trigger error reporting integration
[lttng-tools.git] / tests / regression / Makefile.am
index 874e0c08b5995f59573a6251075a2557a4c20d13..b422480442a189e7983fd7e13cfab7526b48b5da 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
@@ -25,15 +27,31 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/crash/test_crash \
        tools/regen-metadata/test_ust \
        tools/regen-statedump/test_ust \
-       tools/notification/test_notification_ust \
-       tools/notification/test_notification_kernel \
+       tools/notification/test_notification_ust_error \
+       tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
+       tools/notification/test_notification_ust_event_rule_condition_exclusion \
+       tools/notification/test_notification_kernel_error \
+       tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
+       tools/notification/test_notification_kernel_instrumentation \
+       tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_trigger_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
        tools/rotation/test_save_load_mi \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
-       tools/working-directory/test_relayd_working_directory
+       tools/working-directory/test_relayd_working_directory \
+       tools/clear/test_ust \
+       tools/clear/test_kernel \
+       tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli \
+       tools/trigger/test_remove_trigger_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
This page took 0.024668 seconds and 5 git commands to generate.