SoW-2020-0002: Trace Hit Counters: trigger error reporting integration
[lttng-tools.git] / tests / regression / Makefile.am
index c52c3c61491aa1c17ddadde732e8a9df5dedabb1..b422480442a189e7983fd7e13cfab7526b48b5da 100644 (file)
@@ -1,7 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
+LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
 TESTS = tools/filtering/test_invalid_filter \
@@ -19,13 +21,37 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/snapshots/test_ust_streaming \
        tools/save-load/test_save \
        tools/save-load/test_load \
+       tools/save-load/test_autoload \
        tools/mi/test_mi \
        tools/wildcard/test_event_wildcard \
        tools/crash/test_crash \
        tools/regen-metadata/test_ust \
        tools/regen-statedump/test_ust \
-       tools/notification/test_notification \
-       tools/notification/test_notification_multi_app
+       tools/notification/test_notification_ust_error \
+       tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
+       tools/notification/test_notification_ust_event_rule_condition_exclusion \
+       tools/notification/test_notification_kernel_error \
+       tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
+       tools/notification/test_notification_kernel_instrumentation \
+       tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_trigger_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
+       tools/notification/test_notification_multi_app \
+       tools/rotation/test_ust \
+       tools/rotation/test_kernel \
+       tools/rotation/test_save_load_mi \
+       tools/rotation/test_schedule_api \
+       tools/metadata/test_kernel \
+       tools/working-directory/test_relayd_working_directory \
+       tools/clear/test_ust \
+       tools/clear/test_kernel \
+       tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli \
+       tools/trigger/test_remove_trigger_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -42,7 +68,13 @@ TESTS += ust/before-after/test_before_after \
        ust/test_event_basic \
        ust/test_event_tracef \
        ust/test_event_perf \
-       ust/blocking/test_blocking
+       ust/blocking/test_blocking \
+       ust/multi-lib/test_multi_lib \
+       ust/rotation-destroy-flush/test_rotation_destroy_flush \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change \
+       tools/metadata/test_ust \
+       tools/relayd-grouping/test_ust
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.02512 seconds and 5 git commands to generate.