Tests: regression testing for notification API
[lttng-tools.git] / tests / regression / Makefile.am
index 5f4a6e4c063d3e666a0ce89f954a673a8ec514a8..c52c3c61491aa1c17ddadde732e8a9df5dedabb1 100644 (file)
@@ -1,5 +1,6 @@
 SUBDIRS = tools kernel ust
 
+LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
@@ -21,7 +22,10 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/mi/test_mi \
        tools/wildcard/test_event_wildcard \
        tools/crash/test_crash \
-       tools/metadata-regen/test_ust
+       tools/regen-metadata/test_ust \
+       tools/regen-statedump/test_ust \
+       tools/notification/test_notification \
+       tools/notification/test_notification_multi_app
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -36,7 +40,9 @@ TESTS += ust/before-after/test_before_after \
        ust/getcpu-override/test_getcpu_override \
        ust/clock-override/test_clock_override \
        ust/test_event_basic \
-       ust/test_event_tracef
+       ust/test_event_tracef \
+       ust/test_event_perf \
+       ust/blocking/test_blocking
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.024263 seconds and 5 git commands to generate.