tests: Move to kernel style SPDX license identifiers
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index ca73ed43ef6326ef663c423d0ba89409a9481c94..28e0303e20f42d49c30593d1bffccb8770a9214d 100644 (file)
@@ -1,4 +1,16 @@
-EXTRA_DIST = test_event_basic test_all_events test_syscall test_clock_override
+# SPDX-License-Identifier: GPL-2.0-only
+
+EXTRA_DIST = test_event_basic test_all_events test_syscall \
+               test_clock_override test_rotation_destroy_flush \
+               test_select_poll_epoll test_lttng_logger \
+               test_userspace_probe test_callstack \
+               test_syscall validate_select_poll_epoll.py \
+               test_ns_contexts test_ns_contexts_change
+
+noinst_PROGRAMS = select_poll_epoll
+select_poll_epoll_SOURCES = select_poll_epoll.c
+select_poll_epoll_LDADD = $(POPT_LIBS)
+select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.026478 seconds and 5 git commands to generate.