Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index e9ec04ea9593dbfbc61005859a7ea4ff4573c997..92c21bc9fb13413db5d80d8db23e3a7e00e1f9e7 100644 (file)
@@ -1,4 +1,3 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 EXTRA_DIST = test_event_basic test_all_events test_syscall \
                test_clock_override test_rotation_destroy_flush \
                test_select_poll_epoll
@@ -6,7 +5,7 @@ EXTRA_DIST = test_event_basic test_all_events test_syscall \
 noinst_PROGRAMS = select_poll_epoll
 select_poll_epoll_SOURCES = select_poll_epoll.c
 select_poll_epoll_LDADD = -lpthread -lpopt
-select_poll_epoll_CFLAGS = -fno-stack-protector -D_FORTIFY_SOURCE=0
+select_poll_epoll_CFLAGS = -fno-stack-protector -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024563 seconds and 5 git commands to generate.