Fix: support VPATH build for tests
[lttng-tools.git] / tests / regression / tools / health / Makefile.am
index 098fbf421aee5ee9c119b0fc14ecf66cc7ecd6d0..c22d5ee390ab1592583dfe1a93987300a21d81af 100644 (file)
@@ -39,3 +39,17 @@ endif
 
 dist_noinst_SCRIPTS = test_thread_exit test_thread_stall test_tp_fail
 EXTRA_DIST = test_thread_exit test_thread_stall test_tp_fail
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024388 seconds and 5 git commands to generate.