Fix: Don't include the binary in the live test's EXTRA_DIST
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 6551f13e698e81c469a169d356549a32026dc03f..167b9e6ad3765280de65a31c71b45b7450b04735 100644 (file)
@@ -22,16 +22,17 @@ LIVE=$(top_builddir)/src/bin/lttng-sessiond/session.o \
         $(top_builddir)/src/bin/lttng-sessiond/snapshot.o
 
 noinst_PROGRAMS = live_test
-EXTRA_DIST = live_test test_kernel
+EXTRA_DIST = test_kernel
 
 if HAVE_LIBLTTNG_UST_CTL
-EXTRA_DIST += test_ust
+EXTRA_DIST += test_ust test_ust_tracefile_count
 endif
 
 live_test_SOURCES = live_test.c
 live_test_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
-                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt -llttng-ctl
-live_test_LDADD += $(LIVE)
+                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt
+live_test_LDADD += $(LIVE) \
+                                  $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024307 seconds and 5 git commands to generate.