Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 44e4490102a7273a66d44c3e1aafca06a48b1e3a..46186d383583d7c21cf50b0d66e74ea8fb81d099 100644 (file)
@@ -1,12 +1,5 @@
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils/ -I$(srcdir)
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
-
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
 LIBCOMMON=$(top_builddir)/src/common/libcommon.la
@@ -29,9 +22,9 @@ endif
 
 live_test_SOURCES = live_test.c
 live_test_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
-                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt
+               $(LIBHASHTABLE) $(LIBHEALTH) $(DL_LIBS) -lrt
 live_test_LDADD += $(LIVE) \
-                                  $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+               $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.025263 seconds and 5 git commands to generate.