Cleanup: Replace all perror() uses by the PERROR macro
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 6551f13e698e81c469a169d356549a32026dc03f..ea5f417adf44f1e5855a8c3d279d35163d6640a0 100644 (file)
@@ -22,16 +22,17 @@ LIVE=$(top_builddir)/src/bin/lttng-sessiond/session.o \
         $(top_builddir)/src/bin/lttng-sessiond/snapshot.o
 
 noinst_PROGRAMS = live_test
-EXTRA_DIST = live_test test_kernel
+EXTRA_DIST = test_kernel test_lttng_kernel
 
 if HAVE_LIBLTTNG_UST_CTL
-EXTRA_DIST += test_ust
+EXTRA_DIST += test_ust test_ust_tracefile_count test_lttng_ust
 endif
 
 live_test_SOURCES = live_test.c
 live_test_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
-                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt -llttng-ctl
-live_test_LDADD += $(LIVE)
+                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt
+live_test_LDADD += $(LIVE) \
+                                  $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.027053 seconds and 5 git commands to generate.