Fix concurrency issues while overwriting tracefiles in live
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 6551f13e698e81c469a169d356549a32026dc03f..fdf9d3adee53a6b65b956b65bb31ba31e0bae7eb 100644 (file)
@@ -25,13 +25,14 @@ noinst_PROGRAMS = live_test
 EXTRA_DIST = live_test test_kernel
 
 if HAVE_LIBLTTNG_UST_CTL
-EXTRA_DIST += test_ust
+EXTRA_DIST += test_ust test_ust_tracefile_count
 endif
 
 live_test_SOURCES = live_test.c
 live_test_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
-                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt -llttng-ctl
-live_test_LDADD += $(LIVE)
+                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt
+live_test_LDADD += $(LIVE) \
+                                  $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024728 seconds and 5 git commands to generate.