SoW-2020-0002: Trace Hit Counters
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 3aca442f2235db9adb9f90f4e46e0aa4048eeba3..0dceea5721fbe149874a9b511a72cb8c9e3f6cdd 100644 (file)
@@ -9,18 +9,22 @@ noinst_PROGRAMS = base_client notification rotation
 
 if NO_SHARED
 
-CLEANFILES = libpause_consumer.so libpause_consumer.so.debug
+CLEANFILES = libpause_consumer.so libpause_consumer.so.debug libpause_sessiond.so libpause_sessiond.so.debug
 EXTRA_DIST = \
             base_client.c \
             consumer_testpoints.c \
+            sessiond_testpoints.c \
             notification.c \
             test_notification_kernel_buffer_usage \
+            test_notification_kernel_capture \
             test_notification_kernel_error \
             test_notification_kernel_instrumentation \
             test_notification_kernel_syscall \
             test_notification_kernel_userspace_probe \
             test_notification_multi_app \
+            test_notification_notifier_discarded_count \
             test_notification_ust_buffer_usage \
+            test_notification_ust_capture \
             test_notification_ust_error \
             test_notification_ust_event_rule_condition_exclusion \
             util_event_generator.sh
@@ -38,7 +42,14 @@ libpause_consumer_la_LIBADD = \
        $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
        $(DL_LIBS)
 libpause_consumer_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
-noinst_LTLIBRARIES = libpause_consumer.la
+
+libpause_sessiond_la_SOURCES = sessiond_testpoints.c
+libpause_sessiond_la_LIBADD = \
+       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+       $(DL_LIBS)
+libpause_sessiond_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
+noinst_LTLIBRARIES = libpause_sessiond.la libpause_consumer.la
 
 base_client_SOURCES = base_client.c
 base_client_LDADD = $(LIB_LTTNG_CTL)
@@ -56,6 +67,7 @@ noinst_SCRIPTS = \
        test_notification_kernel_syscall \
        test_notification_kernel_userspace_probe \
        test_notification_multi_app \
+       test_notification_notifier_discarded_count \
        test_notification_ust_buffer_usage \
        test_notification_ust_error \
        test_notification_ust_event_rule_condition_exclusion \
@@ -64,12 +76,15 @@ noinst_SCRIPTS = \
 
 EXTRA_DIST = \
        test_notification_kernel_buffer_usage \
+       test_notification_kernel_capture \
        test_notification_kernel_error \
        test_notification_kernel_instrumentation \
        test_notification_kernel_syscall \
        test_notification_kernel_userspace_probe \
        test_notification_multi_app \
+       test_notification_notifier_discarded_count \
        test_notification_ust_buffer_usage \
+       test_notification_ust_capture \
        test_notification_ust_error \
        test_notification_ust_event_rule_condition_exclusion \
        test_rotation \
This page took 0.025057 seconds and 5 git commands to generate.