Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 540b818225083c936336c8ac3e74975b3224a2fc..707047c3a3ce9154dc6888d71e9e2b4db76bc3b6 100644 (file)
@@ -20,7 +20,7 @@ FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                           -rpath $(abs_builddir)
 
 libpause_consumer_la_SOURCES = consumer_testpoints.c
-libpause_consumer_la_LIBADD = $(top_builddir)/src/common/libcommon.la
+libpause_consumer_la_LIBADD = $(top_builddir)/src/common/libcommon.la $(DL_LIBS)
 libpause_consumer_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
 noinst_LTLIBRARIES = libpause_consumer.la
 
@@ -30,13 +30,6 @@ base_client_LDADD = $(LIB_LTTNG_CTL)
 notification_SOURCES = notification.c
 notification_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
-
 noinst_SCRIPTS = test_notification test_notification_multi_app
 EXTRA_DIST = test_notification test_notification_multi_app
 
This page took 0.025031 seconds and 5 git commands to generate.