SoW-2020-0002: Trace Hit Counters: trigger error reporting integration
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 0e7a667014db48a9f7168217a10879be838152e3..c086bcf38b2e2b57d9a7053be51cfda2b702b3d6 100644 (file)
@@ -1,6 +1,6 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests -I$(top_srcdir)/tests/utils/ -I$(srcdir)
-AM_LDFLAGS =
+# SPDX-License-Identifier: GPL-2.0-only
 
+AM_CFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 LIB_LTTNG_CTL = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
@@ -9,9 +9,25 @@ noinst_PROGRAMS = base_client notification rotation
 
 if NO_SHARED
 
-CLEANFILES = libpause_consumer.so libpause_consumer.so.debug
-EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app base_client.c notification.c consumer_testpoints.c
-
+CLEANFILES = libpause_consumer.so libpause_consumer.so.debug libpause_sessiond.so libpause_sessiond.so.debug
+EXTRA_DIST = \
+            base_client.c \
+            consumer_testpoints.c \
+            sessiond_testpoints.c \
+            notification.c \
+            test_notification_kernel_buffer_usage \
+            test_notification_kernel_capture \
+            test_notification_kernel_error \
+            test_notification_kernel_instrumentation \
+            test_notification_kernel_syscall \
+            test_notification_kernel_userspace_probe \
+            test_notification_multi_app \
+            test_notification_trigger_discarded_count \
+            test_notification_ust_buffer_usage \
+            test_notification_ust_capture \
+            test_notification_ust_error \
+            test_notification_ust_event_rule_condition_exclusion \
+            util_event_generator.sh
 else
 
 # In order to test the health check feature, the helper library
@@ -21,11 +37,19 @@ FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
 
 libpause_consumer_la_SOURCES = consumer_testpoints.c
 libpause_consumer_la_LIBADD = \
+       $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
        $(top_builddir)/src/common/libcommon.la \
        $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
        $(DL_LIBS)
 libpause_consumer_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
-noinst_LTLIBRARIES = libpause_consumer.la
+
+libpause_sessiond_la_SOURCES = sessiond_testpoints.c
+libpause_sessiond_la_LIBADD = \
+       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+       $(DL_LIBS)
+libpause_sessiond_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
+noinst_LTLIBRARIES = libpause_sessiond.la libpause_consumer.la
 
 base_client_SOURCES = base_client.c
 base_client_LDADD = $(LIB_LTTNG_CTL)
@@ -36,9 +60,35 @@ notification_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 rotation_SOURCES = rotation.c
 rotation_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
-noinst_SCRIPTS = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
-EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
+noinst_SCRIPTS = \
+       test_notification_kernel_buffer_usage \
+       test_notification_kernel_error \
+       test_notification_kernel_instrumentation \
+       test_notification_kernel_syscall \
+       test_notification_kernel_userspace_probe \
+       test_notification_multi_app \
+       test_notification_trigger_discarded_count \
+       test_notification_ust_buffer_usage \
+       test_notification_ust_error \
+       test_notification_ust_event_rule_condition_exclusion \
+       test_rotation \
+       util_event_generator.sh
 
+EXTRA_DIST = \
+       test_notification_kernel_buffer_usage \
+       test_notification_kernel_capture \
+       test_notification_kernel_error \
+       test_notification_kernel_instrumentation \
+       test_notification_kernel_syscall \
+       test_notification_kernel_userspace_probe \
+       test_notification_multi_app \
+       test_notification_trigger_discarded_count \
+       test_notification_ust_buffer_usage \
+       test_notification_ust_capture \
+       test_notification_ust_error \
+       test_notification_ust_event_rule_condition_exclusion \
+       test_rotation \
+       util_event_generator.sh
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024393 seconds and 5 git commands to generate.