SoW-2020-0002: Trace Hit Counters: trigger error reporting integration
[lttng-tools.git] / tests / regression / tools / rotation / Makefile.am
index 05a88fd11df9d6358f551ac91d1fd2254656dabb..eb81e1976d73fb8a55a80918a8343dc712d09fbc 100644 (file)
@@ -1,5 +1,16 @@
-noinst_SCRIPTS = test_kernel test_ust test_save_load_mi
-EXTRA_DIST = test_kernel test_ust test_save_load_mi
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils/ -I$(srcdir)
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+
+noinst_PROGRAMS = schedule_api
+schedule_api_SOURCES = schedule_api.c
+schedule_api_LDADD = $(LIBTAP) $(LIBLTTNG_CTL)
+
+noinst_SCRIPTS = test_kernel test_ust test_save_load_mi test_schedule_api rotate_utils.sh
+EXTRA_DIST = test_kernel test_ust test_save_load_mi test_schedule_api rotate_utils.sh
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.025461 seconds and 5 git commands to generate.