Fix: support VPATH build for tests
[lttng-tools.git] / tests / regression / tools / streaming / Makefile.am
index 050cdeacc0806821c7497b4fb2ba21dc8a17376d..6519670dec128815e561be2725c2c3f4d3913a1b 100644 (file)
@@ -1,2 +1,16 @@
 noinst_SCRIPTS = test_ust test_kernel test_high_throughput_limits
 EXTRA_DIST = test_ust test_kernel test_high_throughput_limits
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024244 seconds and 5 git commands to generate.