Tests: add duplicated providers tests
[lttng-tools.git] / tests / regression / ust / Makefile.am
index d8904bb78c0227e7186aec989d5aea3cc07d38ef..6237b1610653c12b90f957817fd7e2d1bfc5979e 100644 (file)
@@ -1,7 +1,28 @@
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap
+               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
+               periodical-metadata-flush java-jul java-log4j python-logging \
+               getcpu-override clock-override type-declarations \
+               rotation-destroy-flush blocking multi-lib
 
-EXTRA_DIST = runall.sh run-ust-global-tests.sh test_event_basic test_event_wildcard
+if HAVE_OBJCOPY
+SUBDIRS += baddr-statedump ust-dl
+endif
+
+EXTRA_DIST = test_event_basic test_event_tracef test_event_perf
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.024027 seconds and 5 git commands to generate.