tests: Move to kernel style SPDX license identifiers
[lttng-tools.git] / tests / regression / ust / Makefile.am
index 78a5aab625e480a19b93ace93606ea77d6aa32cf..994fa6a689bfb6d89a4b25ee888334e5170f3d16 100644 (file)
@@ -1,7 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap buffers-uid
+               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
+               periodical-metadata-flush java-jul java-log4j python-logging \
+               getcpu-override clock-override type-declarations \
+               rotation-destroy-flush blocking multi-lib namespaces
+
+if HAVE_OBJCOPY
+SUBDIRS += baddr-statedump ust-dl
+endif
+
+EXTRA_DIST = test_event_basic test_event_tracef test_event_perf
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-EXTRA_DIST = test_event_basic test_event_wildcard
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.024406 seconds and 5 git commands to generate.