Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / ust / clock-override / Makefile.am
index 95065e0ed1ba6b580395be72521dcd1f3f021c2f..61b6d809f990b79a67917dbf5221355ce99d78b3 100644 (file)
@@ -1,4 +1,13 @@
-AM_CPPFLAGS = -I$(srcdir)
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+
+CLEANFILES = lttng-ust-clock-override-test.so \
+       lttng-ust-clock-override-test.so.debug
+
+EXTRA_DIST = test_clock_override lttng-ust-clock-override-test.c
+
+else
 
 # The rpath is necessary because libtool won't build a shared library
 # if it's noinst_
@@ -11,13 +20,8 @@ GETCPU_LIBTOOL_FLAGS = \
 
 noinst_LTLIBRARIES = lttng-ust-clock-override-test.la
 lttng_ust_clock_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-lttng_ust_clock_override_test_la_LIBADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-lttng_ust_clock_override_test_la_LIBADD = -lc
-endif
+lttng_ust_clock_override_test_la_SOURCES = lttng-ust-clock-override-test.c
+lttng_ust_clock_override_test_la_LIBADD = $(DL_LIBS)
 
 noinst_SCRIPTS = test_clock_override
 EXTRA_DIST = test_clock_override
@@ -35,3 +39,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
+endif
This page took 0.026496 seconds and 5 git commands to generate.