Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / ust / clock-override / Makefile.am
index a656548de35c6cbff5abbf36777a94b84d38a06f..61b6d809f990b79a67917dbf5221355ce99d78b3 100644 (file)
@@ -1,4 +1,13 @@
-AM_CPPFLAGS = -I$(srcdir)
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+
+CLEANFILES = lttng-ust-clock-override-test.so \
+       lttng-ust-clock-override-test.so.debug
+
+EXTRA_DIST = test_clock_override lttng-ust-clock-override-test.c
+
+else
 
 # The rpath is necessary because libtool won't build a shared library
 # if it's noinst_
@@ -11,16 +20,11 @@ GETCPU_LIBTOOL_FLAGS = \
 
 noinst_LTLIBRARIES = lttng-ust-clock-override-test.la
 lttng_ust_clock_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
+lttng_ust_clock_override_test_la_SOURCES = lttng-ust-clock-override-test.c
+lttng_ust_clock_override_test_la_LIBADD = $(DL_LIBS)
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-lttng_ust_clock_override_test_la_LIBADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-lttng_ust_clock_override_test_la_LIBADD = -lc
-endif
-
-noinst_SCRIPTS = test_clock_override run-clock-override
-EXTRA_DIST = test_clock_override run-clock-override
+noinst_SCRIPTS = test_clock_override
+EXTRA_DIST = test_clock_override
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
@@ -35,3 +39,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
+endif
This page took 0.024201 seconds and 5 git commands to generate.