Tests: Java agent: update after Java agent refactoring
[lttng-tools.git] / tests / regression / ust / java-jul / Makefile.am
index 286e3df2293611f2888cbd8603529de6c5eea937..877237fffd02d47d37c65630f18b226e34a51836 100644 (file)
@@ -1,25 +1,13 @@
+JAVAROOT = .
 
 noinst_SCRIPTS = test_java_jul JTestLTTng.java
 EXTRA_DIST = test_java_jul JTestLTTng.java
 
-if HAVE_JAVA_JDK
-JCC=$(JAVA_JDK)/bin/javac
-else
-JCC=javac
-endif
+if BUILD_JAVA_JUL_AGENT
+dist_noinst_JAVA = JTestLTTng.java
+endif # BUILD_JAVA_JUL_AGENT
 
-AGENT_JAR_FILE=$(java_agent_jar_path)
-
-
-# Still need to copy test files in case of out of tree build
-if BUILD_JAVA_AGENT
-all-local: static_file JTestLTTng.class
-%.class: %.java
-       $(JCC) -d "$(builddir)" -cp "$(AGENT_JAR_FILE):." $<
-else
 all-local: static_file
-endif # BUILD_JAVA_AGENT
-
 
 static_file:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
@@ -28,7 +16,6 @@ static_file:
                done; \
        fi
 
-
 clean-local:
        rm -f *.class
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024139 seconds and 5 git commands to generate.