Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / ust / low-throughput / Makefile.am
index e62706007a2b097af442fc6adbe676cfe58e8ee6..8ce8f24397eae0a4d358a9f623bd1c738ca3c529 100644 (file)
@@ -1,11 +1,10 @@
-AM_CFLAGS = -I$(srcdir) -O2
-AM_LDFLAGS = -llttng-ust
+AM_CPPFLAGS += -I$(srcdir)
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 noinst_PROGRAMS = gen-events
@@ -14,3 +13,17 @@ gen_events_LDADD = -llttng-ust -lurcu
 
 noinst_SCRIPTS = test_low_throughput
 EXTRA_DIST = test_low_throughput
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.025958 seconds and 5 git commands to generate.