Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / regression / ust / multi-lib / Makefile.am
index 17ccf3e648fda66dc6188e7edfde95bc79931377..0ce46a7ffe376ce53094120a03085974fe561d20 100644 (file)
@@ -7,12 +7,12 @@ exec_with_callsites_LDFLAGS = -ldl $(POPT_LIBS)
 exec_with_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=1
 
 exec_without_callsites_SOURCES = multi-lib-test.c
-exec_without_callsites_LDFLAGS = -ldl $(POPT_LIBS) -llttng-ust
+exec_without_callsites_LDFLAGS = -ldl $(POPT_LIBS) $(UST_LIBS)
 exec_without_callsites_LDADD = probes.o
 exec_without_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=0
 
 PROBES_SRC=probes.c probes.h
-PROBES_LDF=-shared -module -llttng-ust -avoid-version -rpath $(abs_builddir)/.libs/
+PROBES_LDF=-shared -module $(UST_LIBS) -avoid-version -rpath $(abs_builddir)/.libs/
 PROBES_CF=$(AM_CFLAGS) $(AM_CPPFLAGS) $(CFLAGS) $(CPPFLAGS) -c -I$(srcdir)/
 
 probes.o: probes.c probes.h
@@ -29,7 +29,7 @@ noinst_LTLIBRARIES = libprobes_a.la libprobes_a_prime.la \
 noinst_LTLIBRARIES += libcallsites_1.la libcallsites_2.la
 
 CALLSITES_SRC=callsites.c callsites.h
-CALLSITES_LDF=-shared -module -llttng-ust -avoid-version -rpath $(abs_builddir)/.libs/
+CALLSITES_LDF=-shared -module $(UST_LIBS) -avoid-version -rpath $(abs_builddir)/.libs/
 CALLSITES_CF=-c -I.
 
 libprobes_a_la_SOURCES = $(PROBES_SRC)
This page took 0.024146 seconds and 5 git commands to generate.