Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / ust / overlap / demo / Makefile.am
index c5e9f92d589334a93cfbc46a07ba4c6ad4248032..4d4efb154b5542da867b37817199e8e9582d107d 100644 (file)
@@ -1,8 +1,17 @@
-AM_CFLAGS=-I$(srcdir)
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
+
+CLEANFILES = demo
+
+EXTRA_DIST = demo-trace demo.c ust_tests_demo.h \
+       tp3.c ust_tests_demo3.h tp2.c ust_tests_demo2.h \
+       tp.c ust_tests_demo.h
+
 else
+
+AM_CPPFLAGS += -I$(srcdir)
+
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
@@ -49,4 +58,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
 endif
This page took 0.026649 seconds and 5 git commands to generate.