Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / ust / overlap / demo / Makefile.am
index 15f5600d61f0465d6cf6bf72207711d9e3bf6b41..fbb399cd4e3fae2ccaa457614a3ec74f3c0c3b21 100644 (file)
@@ -10,7 +10,7 @@ EXTRA_DIST = demo-trace demo.c ust_tests_demo.h \
 
 else
 
-AM_CFLAGS=-I$(srcdir)
+AM_CPPFLAGS += -I$(srcdir)
 
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
@@ -35,12 +35,7 @@ noinst_LTLIBRARIES = liblttng-ust-provider-ust-tests-demo.la \
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
 # The demo program only depends on libdl/libc for dlopen().
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-demo_LDADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-demo_LDADD = -lc
-endif
+demo_LDADD = $(DL_LIBS)
 
 noinst_SCRIPTS = demo-trace
 EXTRA_DIST = demo-trace
This page took 0.028829 seconds and 5 git commands to generate.