Cleanup: dlmopen detection
[lttng-tools.git] / tests / regression / ust / overlap / demo / Makefile.am
index c5e9f92d589334a93cfbc46a07ba4c6ad4248032..fbb399cd4e3fae2ccaa457614a3ec74f3c0c3b21 100644 (file)
@@ -1,8 +1,17 @@
-AM_CFLAGS=-I$(srcdir)
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
+
+CLEANFILES = demo
+
+EXTRA_DIST = demo-trace demo.c ust_tests_demo.h \
+       tp3.c ust_tests_demo3.h tp2.c ust_tests_demo2.h \
+       tp.c ust_tests_demo.h
+
 else
+
+AM_CPPFLAGS += -I$(srcdir)
+
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
@@ -26,12 +35,7 @@ noinst_LTLIBRARIES = liblttng-ust-provider-ust-tests-demo.la \
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
 # The demo program only depends on libdl/libc for dlopen().
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-demo_LDADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-demo_LDADD = -lc
-endif
+demo_LDADD = $(DL_LIBS)
 
 noinst_SCRIPTS = demo-trace
 EXTRA_DIST = demo-trace
@@ -49,4 +53,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
 endif
This page took 0.025207 seconds and 5 git commands to generate.