Add rmdirat and renameat to run-as commands
[lttng-tools.git] / tests / unit / Makefile.am
index 4ded1dfb12f1d0b77a186b674416d47b7c488a11..460e2f752045656926831500497f27dc7c7618e8 100644 (file)
@@ -15,6 +15,7 @@ TESTS = test_kernel_data \
        test_utils_compat_poll \
        test_string_utils \
        test_notification \
+       test_directory_handle \
        ini_config/test_ini_config
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
@@ -30,7 +31,7 @@ LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 noinst_PROGRAMS = test_uri test_session test_kernel_data \
                   test_utils_parse_size_suffix test_utils_parse_time_suffix \
                   test_utils_expand_path test_utils_compat_poll \
-                  test_string_utils test_notification
+                  test_string_utils test_notification test_directory_handle
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -158,6 +159,10 @@ test_utils_compat_poll_LDADD  = $(LIBTAP) $(LIBHASHTABLE) $(DL_LIBS) \
 test_utils_expand_path_SOURCES = test_utils_expand_path.c
 test_utils_expand_path_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON) $(DL_LIBS)
 
+# directory handle unit test
+test_directory_handle_SOURCES = test_directory_handle.c
+test_directory_handle_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON) $(DL_LIBS)
+
 # string utilities unit test
 test_string_utils_SOURCES = test_string_utils.c
 test_string_utils_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBSTRINGUTILS) $(DL_LIBS)
This page took 0.02475 seconds and 5 git commands to generate.