Fix: Conditionally disable test requiring shared libs
[lttng-tools.git] / tests / ust / overlap / demo / Makefile.am
index e354636bc3a7dd80e1a146f98e51925a55921c31..68b6e087f84f506aeaf9137e43bc659ad9f5f0c9 100644 (file)
@@ -1,5 +1,10 @@
 AM_CFLAGS=-I$(srcdir)
-
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
+# Force the shared flag on the noinst libraries since they are
+# only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                                                   -rpath $(abs_builddir)
 
@@ -30,3 +35,4 @@ endif
 
 noinst_SCRIPTS = demo-trace
 EXTRA_DIST = demo-trace
+endif
This page took 0.024725 seconds and 5 git commands to generate.