Fix: support VPATH build for tests
[lttng-tools.git] / tests / utils / tap / Makefile.am
index d3b5b58f18a6bb401294495d04b7f4b6062e4e6e..0e78398feea29b5d359a910048648cb5d38d1074 100644 (file)
@@ -2,3 +2,17 @@ noinst_LTLIBRARIES = libtap.la
 libtap_la_SOURCES = tap.c tap.h
 dist_noinst_SCRIPTS = tap.sh
 EXTRA_DIST = tap.sh
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.025182 seconds and 5 git commands to generate.