tests: Move to kernel style SPDX license identifiers
[lttng-tools.git] / tests / utils / tap / Makefile.am
index 01df68a6fbf880ee50c265adfab672b8c0a9a45b..f84d91c8ae331061358098a24b601881fd39ed47 100644 (file)
@@ -1,2 +1,20 @@
-lib_LTLIBRARIES = libtap.la
-libtap_la_SOURCES = tap.c
+# SPDX-License-Identifier: GPL-2.0-only
+
+noinst_LTLIBRARIES = libtap.la
+libtap_la_SOURCES = tap.c tap.h
+dist_noinst_SCRIPTS = tap.sh
+EXTRA_DIST = tap.sh
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024583 seconds and 5 git commands to generate.