Tests: add kernel namespace context change tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 036561e307c1b0e38bb5c5c14a52b2b1ee405381..2a4cf5c7ba1ab002532f4a9b9ab6861163a63821 100644 (file)
@@ -1,3 +1,23 @@
-SUBDIRS = gen-ust-events gen-ust-nevents gen-ust-nevents-str gen-ust-tracef
+SUBDIRS = \
+         gen-ns-events \
+         gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         userspace-probe-elf-binary
+
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if SDT_WORKS
+SUBDIRS += userspace-probe-sdt-binary
+endif # SDT_WORKS
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
 noinst_HEADERS = signal-helper.h
This page took 0.024264 seconds and 5 git commands to generate.