Tests: add kernel namespace context change tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index be2758de3ecc4f5032e1fa5f639eb0624c032668..2a4cf5c7ba1ab002532f4a9b9ab6861163a63821 100644 (file)
@@ -1,2 +1,23 @@
-SUBDIRS = gen-ust-events gen-ust-nevents
+SUBDIRS = \
+         gen-ns-events \
+         gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         userspace-probe-elf-binary
 
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if SDT_WORKS
+SUBDIRS += userspace-probe-sdt-binary
+endif # SDT_WORKS
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+
+noinst_HEADERS = signal-helper.h
This page took 0.042895 seconds and 5 git commands to generate.