tests: put -no-pie in LDFLAGS instead of CFLAGS
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 8b631eebcf3b358320737190d10f5c0344181984..76b1c8327ca80b0f448c52df9b9022b3c55ac6b9 100644 (file)
@@ -1,2 +1,25 @@
-SUBDIRS = gen-ust-events
+# SPDX-License-Identifier: GPL-2.0-only
+SUBDIRS = \
+         gen-ns-events \
+         gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         gen-kernel-test-events \
+         userspace-probe-elf-binary
 
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if TEST_SDT_UPROBE
+SUBDIRS += userspace-probe-sdt-binary
+endif # TEST_SDT_UPROBE
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+
+noinst_HEADERS = signal-helper.h
This page took 0.024399 seconds and 5 git commands to generate.