Fix: check for dtrace and sdt.h before enabling SDT uprobe tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 9bfe53666b260d8c6d252a652353b10e31e7213a..e2ad1f2355f6c1f4a3c2fab8a8821d8a98526f5f 100644 (file)
@@ -1,8 +1,20 @@
-SUBDIRS = gen-ust-events \
+SUBDIRS = \
+         gen-ns-events \
+         gen-ust-events \
+         gen-ust-events-ns \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
-         gen-syscall-events
+         gen-syscall-events \
+         userspace-probe-elf-binary
+
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if TEST_SDT_UPROBE
+SUBDIRS += userspace-probe-sdt-binary
+endif # TEST_SDT_UPROBE
 
 if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
This page took 0.024093 seconds and 5 git commands to generate.