Fix: check for dtrace and sdt.h before enabling SDT uprobe tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index be2758de3ecc4f5032e1fa5f639eb0624c032668..e2ad1f2355f6c1f4a3c2fab8a8821d8a98526f5f 100644 (file)
@@ -1,2 +1,23 @@
-SUBDIRS = gen-ust-events gen-ust-nevents
+SUBDIRS = \
+         gen-ns-events \
+         gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         userspace-probe-elf-binary
 
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if TEST_SDT_UPROBE
+SUBDIRS += userspace-probe-sdt-binary
+endif # TEST_SDT_UPROBE
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+
+noinst_HEADERS = signal-helper.h
This page took 0.024209 seconds and 5 git commands to generate.