tests: put -no-pie in LDFLAGS instead of CFLAGS
[lttng-tools.git] / tests / utils / testapp / gen-syscall-events-callstack / Makefile.am
index 4d171ba80c70ed087642ccbd43f34c5b50aa9ccc..3b10c274d2fc6493b580aea940d0659cc207b34c 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CFLAGS += -I$(top_srcdir)/tests/utils/
 AM_CFLAGS += -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer
 #  The feature called Position Independent Execution (PIE) may be enabled by
@@ -8,7 +10,7 @@ AM_CFLAGS += -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer
 #  available, we assume that the PIE is not enabled by default so we do not
 #  need to disable it.
 if LINKER_HAVE_NO_PIE_OPTION
-AM_CFLAGS += -no-pie
+AM_LDFLAGS += -no-pie
 endif
 
 noinst_PROGRAMS = gen-syscall-events-callstack
This page took 0.024283 seconds and 5 git commands to generate.