Tests: Switch test apps to use usleep_safe()
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index 9372423b33c8f5ef531f3f8800fba674f8000acc..0cc7575d7cd0b6c96d9f8f1008caf6d66b9920cc 100644 (file)
@@ -1,5 +1,5 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
+AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
+               -I$(top_srcdir)/tests/utils -I$(srcdir) -O2 -g
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
 LIBS += -ldl
@@ -11,5 +11,6 @@ endif
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust -lurcu-bp
+gen_ust_events_LDADD = -llttng-ust -lurcu-bp \
+               $(top_builddir)/tests/utils/libtestutils.la
 endif
This page took 0.02504 seconds and 5 git commands to generate.