Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index 1be58353c5429b4a696b1f7ad00ea5f031c8b876..38e620d75274515d5635b5381013b199664595a1 100644 (file)
@@ -1,15 +1,10 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
-endif
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust
+gen_ust_events_LDADD = $(UST_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.024093 seconds and 5 git commands to generate.