Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index e11b5f36f34fb8ff22c1eb0aa760cbb2885ad8c0..24f64b2c6ed204a3cf1bdcd242bc8ec91c62e30e 100644 (file)
@@ -1,15 +1,15 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
 gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust
+gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp \
+               $(top_builddir)/tests/utils/libtestutils.la
 endif
This page took 0.024386 seconds and 5 git commands to generate.