Tests: Switch test apps to use usleep_safe()
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index d62c06db99a48cd53ae8a56acf87e01878e99ef9..b3212228fe2a6a852c6e125a4ba4ee9cd486e321 100644 (file)
@@ -1,15 +1,16 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
+AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) \
+               -I$(top_srcdir)/tests/utils -O2 -g
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
 gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp
+gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp \
+               $(top_builddir)/tests/utils/libtestutils.la
 endif
This page took 0.025685 seconds and 5 git commands to generate.